mk: build with _GNU_SOURCE defined by default
[dpdk.git] / lib / librte_eal / meson.build
index 259bb44..a18f3a8 100644 (file)
@@ -18,14 +18,13 @@ elif host_machine.system() == 'freebsd'
        subdir('bsdapp/eal')
 
 else
-       error('unsupported system type @0@'.format(hostmachine.system()))
+       error('unsupported system type "@0@"'.format(host_machine.system()))
 endif
 
-version = 7  # the version of the EAL API
+version = 9  # the version of the EAL API
 allow_experimental_apis = true
 deps += 'compat'
 deps += 'kvargs'
-cflags += '-D_GNU_SOURCE'
 sources = common_sources + env_sources
 objs = common_objs + env_objs
 headers = common_headers + env_headers