mbuf: support dynamic fields and flags
[dpdk.git] / lib / librte_mbuf / meson.build
index 36bb6eb..59fd072 100644 (file)
@@ -2,9 +2,11 @@
 # Copyright(c) 2017 Intel Corporation
 
 version = 5
-sources = files('rte_mbuf.c', 'rte_mbuf_ptype.c', 'rte_mbuf_pool_ops.c')
+sources = files('rte_mbuf.c', 'rte_mbuf_ptype.c', 'rte_mbuf_pool_ops.c',
+       'rte_mbuf_dyn.c')
 headers = files('rte_mbuf.h', 'rte_mbuf_core.h',
-               'rte_mbuf_ptype.h', 'rte_mbuf_pool_ops.h')
+               'rte_mbuf_ptype.h', 'rte_mbuf_pool_ops.h',
+               'rte_mbuf_dyn.h')
 deps += ['mempool']
 
 allow_experimental_apis = true