build: add internal tag check
[dpdk.git] / lib / meson.build
index 0af3efa..07a65a6 100644 (file)
@@ -11,7 +11,9 @@
 libraries = [
        'kvargs', # eal depends on kvargs
        'eal', # everything depends on eal
-       'ring', 'mempool', 'mbuf', 'net', 'meter', 'ethdev', 'pci', # core
+       'ring',
+       'rcu', # rcu depends on ring
+       'mempool', 'mbuf', 'net', 'meter', 'ethdev', 'pci', # core
        'cmdline',
        'metrics', # bitrate/latency stats depends on this
        'hash',    # efd depends on this
@@ -22,7 +24,7 @@ libraries = [
        'gro', 'gso', 'ip_frag', 'jobstats',
        'kni', 'latencystats', 'lpm', 'member',
        'power', 'pdump', 'rawdev',
-       'rcu', 'rib', 'reorder', 'sched', 'security', 'stack', 'vhost',
+       'rib', 'reorder', 'sched', 'security', 'stack', 'vhost',
        # ipsec lib depends on net, crypto and security
        'ipsec',
        #fib lib depends on rib
@@ -37,6 +39,9 @@ if is_windows
 endif
 
 default_cflags = machine_args
+default_cflags += ['-DALLOW_EXPERIMENTAL_API']
+default_cflags += ['-DALLOW_INTERNAL_API']
+
 if cc.has_argument('-Wno-format-truncation')
        default_cflags += '-Wno-format-truncation'
 endif
@@ -47,7 +52,6 @@ foreach l:libraries
        build = true
        reason = '<unknown reason>' # set if build == false to explain why
        name = l
-       allow_experimental_apis = false
        use_function_versioning = false
        sources = []
        headers = []
@@ -98,9 +102,6 @@ foreach l:libraries
                        static_dep = shared_dep
                else
 
-                       if allow_experimental_apis
-                               cflags += '-DALLOW_EXPERIMENTAL_API'
-                       endif
                        if use_function_versioning
                                cflags += '-DRTE_USE_FUNCTION_VERSIONING'
                        endif
@@ -108,15 +109,15 @@ foreach l:libraries
                        version_map = '@0@/@1@/rte_@2@_version.map'.format(
                                        meson.current_source_dir(), dir_name, name)
 
-                       is_experimental = run_command(is_experimental_cmd,
-                                       files(version_map)).returncode()
+                       is_stable = run_command(is_stable_cmd,
+                                       files(version_map)).returncode() == 0
 
-                       if is_experimental != 0
-                               lib_version = experimental_abi_version
-                               so_version = experimental_so_version
-                       else
+                       if is_stable
                                lib_version = abi_version
                                so_version = stable_so_version
+                       else
+                               lib_version = experimental_abi_version
+                               so_version = experimental_so_version
                        endif
 
                        # first build static lib
@@ -148,21 +149,25 @@ foreach l:libraries
                                command: [map_to_def_cmd, '@INPUT@', '@OUTPUT@'],
                                input: version_map,
                                output: 'rte_@0@_exports.def'.format(name))
-                       lk_deps = [version_map, def_file]
-                       if is_windows
+
+                       if is_ms_linker
                                lk_args = ['-Wl,/def:' + def_file.full_path(),
                                        '-Wl,/implib:lib\\' + implib]
                        else
                                lk_args = ['-Wl,--version-script=' + version_map]
+                       endif
+
+                       lk_deps = [version_map, def_file]
+                       if not is_windows
                                # on unix systems check the output of the
-                               # experimental syms script, using it as a
+                               # check-symbols.sh script, using it as a
                                # dependency of the .so build
-                               lk_deps += custom_target(name + '.exp_chk',
-                                       command: [check_experimental_syms,
+                               lk_deps += custom_target(name + '.sym_chk',
+                                       command: [check_symbols,
                                                version_map, '@INPUT@'],
                                        capture: true,
                                        input: static_lib,
-                                       output: name + '.exp_chk')
+                                       output: name + '.sym_chk')
                        endif
 
                        shared_lib = shared_library(libname,