mk: build with _GNU_SOURCE defined by default
[dpdk.git] / lib / meson.build
index 11299d0..24351cc 100644 (file)
@@ -9,12 +9,13 @@
 # given as a dep, no need to mention ring. This is especially true for the
 # core libs which are widely reused, so their deps are kept to a minimum.
 libraries = [ 'compat', # just a header, used for versioning
-       'eal', 'ring', 'mempool', 'mbuf', 'net', 'kvargs', 'ether', 'pci', # core
+       'kvargs',
+       'eal', 'ring', 'mempool', 'mbuf', 'net', 'ethdev', 'pci', # core
        'metrics', # bitrate/latency stats depends on this
        'hash',    # efd depends on this
        'timer',   # eventdev depends on this
        'acl', 'bbdev', 'bitratestats', 'cfgfile',
-       'cmdline', 'cryptodev',
+       'cmdline', 'compressdev', 'cryptodev',
        'distributor', 'efd', 'eventdev',
        'gro', 'gso', 'ip_frag', 'jobstats',
        'kni', 'latencystats', 'lpm', 'member',
@@ -23,7 +24,17 @@ libraries = [ 'compat', # just a header, used for versioning
        # add pkt framework libs which use other libs from above
        'port', 'table', 'pipeline',
        # flow_classify lib depends on pkt framework table lib
-       'flow_classify']
+       'flow_classify', 'bpf']
+
+default_cflags = machine_args
+if cc.has_argument('-Wno-format-truncation')
+       default_cflags += '-Wno-format-truncation'
+endif
+
+enabled_libs = [] # used to print summary at the end
+
+# -D_GNU_SOURCE unconditionally
+default_cflags += '-D_GNU_SOURCE'
 
 foreach l:libraries
        build = true
@@ -33,22 +44,24 @@ foreach l:libraries
        sources = []
        headers = []
        includes = []
-       cflags = machine_args
+       cflags = default_cflags
        objs = [] # other object files to link against, used e.g. for
                  # instruction-set optimized versions of code
 
        # use "deps" for internal DPDK dependencies, and "ext_deps" for
        # external package/library requirements
        ext_deps = []
-       deps = ['eal']   # eal is standard dependency except for itself
-       if l == 'eal'
-               deps = []
+       deps = []
+       # eal is standard dependency once built
+       if dpdk_conf.has('RTE_LIBRTE_EAL')
+               deps += ['eal']
        endif
 
        dir_name = 'librte_' + l
        subdir(dir_name)
 
        if build
+               enabled_libs += name
                dpdk_conf.set('RTE_LIBRTE_' + name.to_upper(), 1)
                install_headers(headers)
 
@@ -63,6 +76,10 @@ foreach l:libraries
                        shared_deps = ext_deps
                        static_deps = ext_deps
                        foreach d:deps
+                               if not is_variable('shared_rte_' + d)
+                                       error('Missing dependency ' + d +
+                                               ' for library ' + lib_name)
+                               endif
                                shared_deps += [get_variable('shared_rte_' + d)]
                                static_deps += [get_variable('static_rte_' + d)]
                        endforeach
@@ -95,7 +112,7 @@ foreach l:libraries
 
                        # then use pre-build objects to build shared lib
                        sources = []
-                       objs += static_lib.extract_all_objects()
+                       objs += static_lib.extract_all_objects(recursive: false)
                        version_map = '@0@/@1@/rte_@2@_version.map'.format(
                                        meson.current_source_dir(), dir_name, name)
                        shared_lib = shared_library(libname,