mk: build with _GNU_SOURCE defined by default
[dpdk.git] / lib / meson.build
index 3acc67e..24351cc 100644 (file)
@@ -32,6 +32,10 @@ if cc.has_argument('-Wno-format-truncation')
 endif
 
 enabled_libs = [] # used to print summary at the end
+
+# -D_GNU_SOURCE unconditionally
+default_cflags += '-D_GNU_SOURCE'
+
 foreach l:libraries
        build = true
        name = l