mk: build with _GNU_SOURCE defined by default
[dpdk.git] / lib / meson.build
index a4f5f28..24351cc 100644 (file)
@@ -1,37 +1,6 @@
-#   BSD LICENSE
-#
-#   Copyright(c) 2017 Intel Corporation.
-#   All rights reserved.
-#
-#   Redistribution and use in source and binary forms, with or without
-#   modification, are permitted provided that the following conditions
-#   are met:
-#
-#     * Redistributions of source code must retain the above copyright
-#       notice, this list of conditions and the following disclaimer.
-#     * Redistributions in binary form must reproduce the above copyright
-#       notice, this list of conditions and the following disclaimer in
-#       the documentation and/or other materials provided with the
-#       distribution.
-#     * Neither the name of Intel Corporation nor the names of its
-#       contributors may be used to endorse or promote products derived
-#       from this software without specific prior written permission.
-#
-#   THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-#   "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-#   LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-#   A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-#   OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-#   SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-#   LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-#   DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-#   THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-#   (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-#   OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# special case for eal, not a simple lib, and compat, just a header
-subdir('librte_eal')
-subdir('librte_compat')
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
 
 # process all libraries equally, as far as possible
 # "core" libs first, then others alphebetically as far as possible
@@ -39,21 +8,33 @@ subdir('librte_compat')
 # sometimes skip deps that would be implied by others, e.g. if mempool is
 # given as a dep, no need to mention ring. This is especially true for the
 # core libs which are widely reused, so their deps are kept to a minimum.
-libraries = ['ring', 'mempool', 'mbuf', 'net', 'ether', 'pci', # core
+libraries = [ 'compat', # just a header, used for versioning
+       'kvargs',
+       'eal', 'ring', 'mempool', 'mbuf', 'net', 'ethdev', 'pci', # core
        'metrics', # bitrate/latency stats depends on this
        'hash',    # efd depends on this
-       'kvargs',  # cryptodev depends on this
+       'timer',   # eventdev depends on this
        'acl', 'bbdev', 'bitratestats', 'cfgfile',
-       'cmdline', 'cryptodev',
+       'cmdline', 'compressdev', 'cryptodev',
        'distributor', 'efd', 'eventdev',
        'gro', 'gso', 'ip_frag', 'jobstats',
        'kni', 'latencystats', 'lpm', 'member',
-       'meter', 'power', 'pdump',
-       'reorder', 'sched', 'security', 'timer', 'vhost',
+       'meter', 'power', 'pdump', 'rawdev',
+       'reorder', 'sched', 'security', 'vhost',
        # add pkt framework libs which use other libs from above
        'port', 'table', 'pipeline',
        # flow_classify lib depends on pkt framework table lib
-       'flow_classify']
+       'flow_classify', 'bpf']
+
+default_cflags = machine_args
+if cc.has_argument('-Wno-format-truncation')
+       default_cflags += '-Wno-format-truncation'
+endif
+
+enabled_libs = [] # used to print summary at the end
+
+# -D_GNU_SOURCE unconditionally
+default_cflags += '-D_GNU_SOURCE'
 
 foreach l:libraries
        build = true
@@ -62,48 +43,97 @@ foreach l:libraries
        allow_experimental_apis = false
        sources = []
        headers = []
-       cflags = []
-       objs = [] # other object files to link against, used e.g. for instruction-
-                 # optimized versions of code
+       includes = []
+       cflags = default_cflags
+       objs = [] # other object files to link against, used e.g. for
+                 # instruction-set optimized versions of code
+
        # use "deps" for internal DPDK dependencies, and "ext_deps" for
        # external package/library requirements
-       deps = ['eal']
        ext_deps = []
+       deps = []
+       # eal is standard dependency once built
+       if dpdk_conf.has('RTE_LIBRTE_EAL')
+               deps += ['eal']
+       endif
 
        dir_name = 'librte_' + l
        subdir(dir_name)
 
        if build
+               enabled_libs += name
                dpdk_conf.set('RTE_LIBRTE_' + name.to_upper(), 1)
                install_headers(headers)
 
-               dep_objs = ext_deps
-               foreach d:deps
-                       dep_objs += [get_variable('dep_rte_' + d)]
-               endforeach
+               libname = 'rte_' + name
+               includes += include_directories(dir_name)
+
+               if sources.length() == 0
+                       # if no C files, just set a dependency on header path
+                       shared_dep = declare_dependency(include_directories: includes)
+                       static_dep = shared_dep
+               else
+                       shared_deps = ext_deps
+                       static_deps = ext_deps
+                       foreach d:deps
+                               if not is_variable('shared_rte_' + d)
+                                       error('Missing dependency ' + d +
+                                               ' for library ' + lib_name)
+                               endif
+                               shared_deps += [get_variable('shared_rte_' + d)]
+                               static_deps += [get_variable('static_rte_' + d)]
+                       endforeach
 
-               if allow_experimental_apis
-                       cflags += '-DALLOW_EXPERIMENTAL_API'
-               endif
+                       if allow_experimental_apis
+                               cflags += '-DALLOW_EXPERIMENTAL_API'
+                       endif
 
-               version_map = '@0@/@1@/rte_@2@_version.map'.format(
-                               meson.current_source_dir(), dir_name, name)
-               libname = 'rte_' + name
-               lib = library(libname,
-                               sources,
-                               objects: objs,
-                               c_args: cflags,
-                               dependencies: dep_objs,
-                               include_directories: include_directories(dir_name),
-                               link_args: '-Wl,--version-script=' + version_map,
-                               link_depends: version_map,
-                               version: '@0@.1'.format(version),
-                               install: true)
-               dep = declare_dependency(link_with: lib,
-                               include_directories: include_directories(dir_name),
-                               dependencies: dep_objs)
-               set_variable('dep_' + libname, dep)
-
-               dpdk_libraries = [lib] + dpdk_libraries
-       endif
+                       if get_option('per_library_versions')
+                               lib_version = '@0@.1'.format(version)
+                               so_version = '@0@'.format(version)
+                       else
+                               prj_ver = meson.project_version().split('.')
+                               lib_version = '@0@.@1@'.format(
+                                               prj_ver.get(0), prj_ver.get(1))
+                               so_version = lib_version
+                       endif
+
+                       # first build static lib
+                       static_lib = static_library(libname,
+                                       sources,
+                                       objects: objs,
+                                       c_args: cflags,
+                                       dependencies: static_deps,
+                                       include_directories: includes,
+                                       install: true)
+                       static_dep = declare_dependency(link_with: static_lib,
+                                       include_directories: includes,
+                                       dependencies: static_deps)
+
+                       # then use pre-build objects to build shared lib
+                       sources = []
+                       objs += static_lib.extract_all_objects(recursive: false)
+                       version_map = '@0@/@1@/rte_@2@_version.map'.format(
+                                       meson.current_source_dir(), dir_name, name)
+                       shared_lib = shared_library(libname,
+                                       sources,
+                                       objects: objs,
+                                       c_args: cflags,
+                                       dependencies: shared_deps,
+                                       include_directories: includes,
+                                       link_args: '-Wl,--version-script=' + version_map,
+                                       link_depends: version_map,
+                                       version: lib_version,
+                                       soversion: so_version,
+                                       install: true)
+                       shared_dep = declare_dependency(link_with: shared_lib,
+                                       include_directories: includes,
+                                       dependencies: shared_deps)
+
+                       dpdk_libraries = [shared_lib] + dpdk_libraries
+               endif # sources.length() > 0
+
+               set_variable('shared_' + libname, shared_dep)
+               set_variable('static_' + libname, static_dep)
+       endif # if build
 endforeach