mk: build with _GNU_SOURCE defined by default
[dpdk.git] / lib / meson.build
index d7836d7..24351cc 100644 (file)
@@ -1,33 +1,5 @@
-#   BSD LICENSE
-#
-#   Copyright(c) 2017 Intel Corporation.
-#   All rights reserved.
-#
-#   Redistribution and use in source and binary forms, with or without
-#   modification, are permitted provided that the following conditions
-#   are met:
-#
-#     * Redistributions of source code must retain the above copyright
-#       notice, this list of conditions and the following disclaimer.
-#     * Redistributions in binary form must reproduce the above copyright
-#       notice, this list of conditions and the following disclaimer in
-#       the documentation and/or other materials provided with the
-#       distribution.
-#     * Neither the name of Intel Corporation nor the names of its
-#       contributors may be used to endorse or promote products derived
-#       from this software without specific prior written permission.
-#
-#   THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-#   "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-#   LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-#   A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-#   OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-#   SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-#   LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-#   DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-#   THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-#   (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-#   OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
 
 
 # process all libraries equally, as far as possible
 # given as a dep, no need to mention ring. This is especially true for the
 # core libs which are widely reused, so their deps are kept to a minimum.
 libraries = [ 'compat', # just a header, used for versioning
-       'eal', 'ring', 'mempool', 'mbuf', 'net', 'ether', 'pci', # core
+       'kvargs',
+       'eal', 'ring', 'mempool', 'mbuf', 'net', 'ethdev', 'pci', # core
        'metrics', # bitrate/latency stats depends on this
        'hash',    # efd depends on this
-       'kvargs',  # cryptodev depends on this
+       'timer',   # eventdev depends on this
        'acl', 'bbdev', 'bitratestats', 'cfgfile',
-       'cmdline', 'cryptodev',
+       'cmdline', 'compressdev', 'cryptodev',
        'distributor', 'efd', 'eventdev',
        'gro', 'gso', 'ip_frag', 'jobstats',
        'kni', 'latencystats', 'lpm', 'member',
-       'meter', 'power', 'pdump',
-       'reorder', 'sched', 'security', 'timer', 'vhost',
+       'meter', 'power', 'pdump', 'rawdev',
+       'reorder', 'sched', 'security', 'vhost',
        # add pkt framework libs which use other libs from above
        'port', 'table', 'pipeline',
        # flow_classify lib depends on pkt framework table lib
-       'flow_classify']
+       'flow_classify', 'bpf']
+
+default_cflags = machine_args
+if cc.has_argument('-Wno-format-truncation')
+       default_cflags += '-Wno-format-truncation'
+endif
+
+enabled_libs = [] # used to print summary at the end
+
+# -D_GNU_SOURCE unconditionally
+default_cflags += '-D_GNU_SOURCE'
 
 foreach l:libraries
        build = true
@@ -61,22 +44,24 @@ foreach l:libraries
        sources = []
        headers = []
        includes = []
-       cflags = []
+       cflags = default_cflags
        objs = [] # other object files to link against, used e.g. for
                  # instruction-set optimized versions of code
 
        # use "deps" for internal DPDK dependencies, and "ext_deps" for
        # external package/library requirements
        ext_deps = []
-       deps = ['eal']   # eal is standard dependency except for itself
-       if l == 'eal'
-               deps = []
+       deps = []
+       # eal is standard dependency once built
+       if dpdk_conf.has('RTE_LIBRTE_EAL')
+               deps += ['eal']
        endif
 
        dir_name = 'librte_' + l
        subdir(dir_name)
 
        if build
+               enabled_libs += name
                dpdk_conf.set('RTE_LIBRTE_' + name.to_upper(), 1)
                install_headers(headers)
 
@@ -85,11 +70,18 @@ foreach l:libraries
 
                if sources.length() == 0
                        # if no C files, just set a dependency on header path
-                       dep = declare_dependency(include_directories: includes)
+                       shared_dep = declare_dependency(include_directories: includes)
+                       static_dep = shared_dep
                else
-                       dep_objs = ext_deps
+                       shared_deps = ext_deps
+                       static_deps = ext_deps
                        foreach d:deps
-                               dep_objs += [get_variable('dep_rte_' + d)]
+                               if not is_variable('shared_rte_' + d)
+                                       error('Missing dependency ' + d +
+                                               ' for library ' + lib_name)
+                               endif
+                               shared_deps += [get_variable('shared_rte_' + d)]
+                               static_deps += [get_variable('static_rte_' + d)]
                        endforeach
 
                        if allow_experimental_apis
@@ -106,26 +98,42 @@ foreach l:libraries
                                so_version = lib_version
                        endif
 
+                       # first build static lib
+                       static_lib = static_library(libname,
+                                       sources,
+                                       objects: objs,
+                                       c_args: cflags,
+                                       dependencies: static_deps,
+                                       include_directories: includes,
+                                       install: true)
+                       static_dep = declare_dependency(link_with: static_lib,
+                                       include_directories: includes,
+                                       dependencies: static_deps)
+
+                       # then use pre-build objects to build shared lib
+                       sources = []
+                       objs += static_lib.extract_all_objects(recursive: false)
                        version_map = '@0@/@1@/rte_@2@_version.map'.format(
                                        meson.current_source_dir(), dir_name, name)
-                       lib = library(libname,
+                       shared_lib = shared_library(libname,
                                        sources,
                                        objects: objs,
                                        c_args: cflags,
-                                       dependencies: dep_objs,
+                                       dependencies: shared_deps,
                                        include_directories: includes,
                                        link_args: '-Wl,--version-script=' + version_map,
                                        link_depends: version_map,
                                        version: lib_version,
                                        soversion: so_version,
                                        install: true)
-                       dep = declare_dependency(link_with: lib,
+                       shared_dep = declare_dependency(link_with: shared_lib,
                                        include_directories: includes,
-                                       dependencies: dep_objs)
+                                       dependencies: shared_deps)
 
-                       dpdk_libraries = [lib] + dpdk_libraries
+                       dpdk_libraries = [shared_lib] + dpdk_libraries
                endif # sources.length() > 0
 
-               set_variable('dep_' + libname, dep)
+               set_variable('shared_' + libname, shared_dep)
+               set_variable('static_' + libname, static_dep)
        endif # if build
 endforeach