test mbuf attach
[dpdk.git] / lib / meson.build
index 80c37af..3852c01 100644 (file)
@@ -40,7 +40,7 @@ if is_windows
                'kvargs',
                'eal',
                'ring',
-               'pci',
+               'mempool', 'mbuf', 'pci',
        ] # only supported libraries for windows
 endif
 
@@ -107,25 +107,15 @@ foreach l:libraries
                        shared_dep = declare_dependency(include_directories: includes)
                        static_dep = shared_dep
                else
+                       if is_windows and use_function_versioning
+                               message('@0@: Function versioning is not supported by Windows.'
+                               .format(name))
+                       endif
 
                        if use_function_versioning
                                cflags += '-DRTE_USE_FUNCTION_VERSIONING'
                        endif
 
-                       version_map = '@0@/@1@/rte_@2@_version.map'.format(
-                                       meson.current_source_dir(), dir_name, name)
-
-                       is_stable = run_command(is_stable_cmd,
-                                       files(version_map)).returncode() == 0
-
-                       if is_stable
-                               lib_version = abi_version
-                               so_version = stable_so_version
-                       else
-                               lib_version = experimental_abi_version
-                               so_version = experimental_so_version
-                       endif
-
                        # first build static lib
                        static_lib = static_library(libname,
                                        sources,
@@ -138,7 +128,7 @@ foreach l:libraries
                                        include_directories: includes,
                                        dependencies: static_deps)
 
-                       if not use_function_versioning
+                       if not use_function_versioning or is_windows
                                # use pre-build objects to build shared lib
                                sources = []
                                objs += static_lib.extract_all_objects(recursive: false)
@@ -193,7 +183,7 @@ foreach l:libraries
                                        include_directories: includes,
                                        link_args: lk_args,
                                        link_depends: lk_deps,
-                                       version: lib_version,
+                                       version: abi_version,
                                        soversion: so_version,
                                        install: true)
                        shared_dep = declare_dependency(link_with: shared_lib,