build: generate Windows exports file
[dpdk.git] / lib / meson.build
index 24351cc..992091a 100644 (file)
@@ -1,5 +1,5 @@
 # SPDX-License-Identifier: BSD-3-Clause
-# Copyright(c) 2017 Intel Corporation
+# Copyright(c) 2017-2019 Intel Corporation
 
 
 # process all libraries equally, as far as possible
@@ -8,23 +8,31 @@
 # sometimes skip deps that would be implied by others, e.g. if mempool is
 # given as a dep, no need to mention ring. This is especially true for the
 # core libs which are widely reused, so their deps are kept to a minimum.
-libraries = [ 'compat', # just a header, used for versioning
-       'kvargs',
-       'eal', 'ring', 'mempool', 'mbuf', 'net', 'ethdev', 'pci', # core
+libraries = [
+       'kvargs', # eal depends on kvargs
+       'eal', # everything depends on eal
+       'cmdline', # ethdev depends on cmdline for parsing functions
+       'ring', 'mempool', 'mbuf', 'net', 'meter', 'ethdev', 'pci', # core
        'metrics', # bitrate/latency stats depends on this
        'hash',    # efd depends on this
        'timer',   # eventdev depends on this
        'acl', 'bbdev', 'bitratestats', 'cfgfile',
-       'cmdline', 'compressdev', 'cryptodev',
+       'compressdev', 'cryptodev',
        'distributor', 'efd', 'eventdev',
        'gro', 'gso', 'ip_frag', 'jobstats',
        'kni', 'latencystats', 'lpm', 'member',
-       'meter', 'power', 'pdump', 'rawdev',
-       'reorder', 'sched', 'security', 'vhost',
+       'power', 'pdump', 'rawdev',
+       'rcu', 'reorder', 'sched', 'security', 'stack', 'vhost',
+       #ipsec lib depends on crypto and security
+       'ipsec',
        # add pkt framework libs which use other libs from above
        'port', 'table', 'pipeline',
        # flow_classify lib depends on pkt framework table lib
-       'flow_classify', 'bpf']
+       'flow_classify', 'bpf', 'telemetry']
+
+if is_windows
+       libraries = ['kvargs','eal'] # only supported libraries for windows
+endif
 
 default_cflags = machine_args
 if cc.has_argument('-Wno-format-truncation')
@@ -78,7 +86,7 @@ foreach l:libraries
                        foreach d:deps
                                if not is_variable('shared_rte_' + d)
                                        error('Missing dependency ' + d +
-                                               ' for library ' + lib_name)
+                                               ' for library ' + libname)
                                endif
                                shared_deps += [get_variable('shared_rte_' + d)]
                                static_deps += [get_variable('static_rte_' + d)]
@@ -92,10 +100,8 @@ foreach l:libraries
                                lib_version = '@0@.1'.format(version)
                                so_version = '@0@'.format(version)
                        else
-                               prj_ver = meson.project_version().split('.')
-                               lib_version = '@0@.@1@'.format(
-                                               prj_ver.get(0), prj_ver.get(1))
-                               so_version = lib_version
+                               lib_version = major_version
+                               so_version = major_version
                        endif
 
                        # first build static lib
@@ -115,14 +121,27 @@ foreach l:libraries
                        objs += static_lib.extract_all_objects(recursive: false)
                        version_map = '@0@/@1@/rte_@2@_version.map'.format(
                                        meson.current_source_dir(), dir_name, name)
+                       implib = dir_name + '.dll.a'
+
+                       def_file = custom_target(name + '_def',
+                               command: [map_to_def_cmd, '@INPUT@', '@OUTPUT@'],
+                               input: version_map,
+                               output: 'rte_@0@_exports.def'.format(name))
+                       if is_windows
+                               lk_args = ['-Wl,/def:' + def_file.full_path(),
+                                       '-Wl,/implib:lib\\' + implib]
+                       else
+                               lk_args = ['-Wl,--version-script=' + version_map]
+                       endif
+
                        shared_lib = shared_library(libname,
                                        sources,
                                        objects: objs,
                                        c_args: cflags,
                                        dependencies: shared_deps,
                                        include_directories: includes,
-                                       link_args: '-Wl,--version-script=' + version_map,
-                                       link_depends: version_map,
+                                       link_args: lk_args,
+                                       link_depends: [version_map, def_file],
                                        version: lib_version,
                                        soversion: so_version,
                                        install: true)
@@ -131,6 +150,7 @@ foreach l:libraries
                                        dependencies: shared_deps)
 
                        dpdk_libraries = [shared_lib] + dpdk_libraries
+                       dpdk_static_libraries = [static_lib] + dpdk_static_libraries
                endif # sources.length() > 0
 
                set_variable('shared_' + libname, shared_dep)