lib: check experimental symbols with meson
[dpdk.git] / lib / meson.build
index a7eded6..bc8eb1d 100644 (file)
@@ -25,6 +25,8 @@ libraries = [
        'rcu', 'rib', 'reorder', 'sched', 'security', 'stack', 'vhost',
        # ipsec lib depends on net, crypto and security
        'ipsec',
+       #fib lib depends on rib
+       'fib',
        # add pkt framework libs which use other libs from above
        'port', 'table', 'pipeline',
        # flow_classify lib depends on pkt framework table lib
@@ -141,11 +143,21 @@ foreach l:libraries
                                command: [map_to_def_cmd, '@INPUT@', '@OUTPUT@'],
                                input: version_map,
                                output: 'rte_@0@_exports.def'.format(name))
+                       lk_deps = [version_map, def_file]
                        if is_windows
                                lk_args = ['-Wl,/def:' + def_file.full_path(),
                                        '-Wl,/implib:lib\\' + implib]
                        else
                                lk_args = ['-Wl,--version-script=' + version_map]
+                               # on unix systems check the output of the
+                               # experimental syms script, using it as a
+                               # dependency of the .so build
+                               lk_deps += custom_target(name + '.exp_chk',
+                                       command: [check_experimental_syms,
+                                               version_map, '@INPUT@'],
+                                       capture: true,
+                                       input: static_lib,
+                                       output: name + '.exp_chk')
                        endif
 
                        shared_lib = shared_library(libname,
@@ -155,7 +167,7 @@ foreach l:libraries
                                        dependencies: shared_deps,
                                        include_directories: includes,
                                        link_args: lk_args,
-                                       link_depends: [version_map, def_file],
+                                       link_depends: lk_deps,
                                        version: lib_version,
                                        soversion: so_version,
                                        install: true)