build: generate version map file for MinGW
[dpdk.git] / lib / meson.build
index 5ac94cd..cbcb985 100644 (file)
@@ -10,6 +10,7 @@
 # core libs which are widely reused, so their deps are kept to a minimum.
 libraries = [
        'kvargs', # eal depends on kvargs
+       'telemetry', # basic info querying
        'eal', # everything depends on eal
        'ring',
        'rcu', # rcu depends on ring
@@ -32,7 +33,7 @@ libraries = [
        # add pkt framework libs which use other libs from above
        'port', 'table', 'pipeline',
        # flow_classify lib depends on pkt framework table lib
-       'flow_classify', 'bpf', 'graph', 'telemetry']
+       'flow_classify', 'bpf', 'graph', 'node']
 
 if is_windows
        libraries = ['kvargs','eal'] # only supported libraries for windows
@@ -145,19 +146,28 @@ foreach l:libraries
                                        meson.current_source_dir(), dir_name, name)
                        implib = dir_name + '.dll.a'
 
-                       def_file = custom_target(name + '_def',
-                               command: [map_to_def_cmd, '@INPUT@', '@OUTPUT@'],
+                       def_file = custom_target(libname + '_def',
+                               command: [map_to_win_cmd, '@INPUT@', '@OUTPUT@'],
                                input: version_map,
-                               output: 'rte_@0@_exports.def'.format(name))
+                               output: '@0@_exports.def'.format(libname))
+
+                       mingw_map = custom_target(libname + '_mingw',
+                               command: [map_to_win_cmd, '@INPUT@', '@OUTPUT@'],
+                               input: version_map,
+                               output: '@0@_mingw.map'.format(libname))
 
                        if is_ms_linker
                                lk_args = ['-Wl,/def:' + def_file.full_path(),
                                        '-Wl,/implib:lib\\' + implib]
                        else
-                               lk_args = ['-Wl,--version-script=' + version_map]
+                               if is_windows
+                                       lk_args = ['-Wl,--version-script=' + mingw_map.full_path()]
+                               else
+                                       lk_args = ['-Wl,--version-script=' + version_map]
+                               endif
                        endif
 
-                       lk_deps = [version_map, def_file]
+                       lk_deps = [version_map, def_file, mingw_map]
                        if not is_windows
                                # on unix systems check the output of the
                                # check-symbols.sh script, using it as a
@@ -187,6 +197,9 @@ foreach l:libraries
 
                        dpdk_libraries = [shared_lib] + dpdk_libraries
                        dpdk_static_libraries = [static_lib] + dpdk_static_libraries
+                       if libname == 'rte_node'
+                               dpdk_graph_nodes = [static_lib]
+                       endif
                endif # sources.length() > 0
 
                set_variable('shared_rte_' + name, shared_dep)