build: remove architecture flag as default C flag
[dpdk.git] / lib / meson.build
index d7836d7..e8302fb 100644 (file)
@@ -1,33 +1,5 @@
-#   BSD LICENSE
-#
-#   Copyright(c) 2017 Intel Corporation.
-#   All rights reserved.
-#
-#   Redistribution and use in source and binary forms, with or without
-#   modification, are permitted provided that the following conditions
-#   are met:
-#
-#     * Redistributions of source code must retain the above copyright
-#       notice, this list of conditions and the following disclaimer.
-#     * Redistributions in binary form must reproduce the above copyright
-#       notice, this list of conditions and the following disclaimer in
-#       the documentation and/or other materials provided with the
-#       distribution.
-#     * Neither the name of Intel Corporation nor the names of its
-#       contributors may be used to endorse or promote products derived
-#       from this software without specific prior written permission.
-#
-#   THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-#   "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-#   LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-#   A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-#   OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-#   SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-#   LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-#   DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-#   THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-#   (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-#   OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
 
 
 # process all libraries equally, as far as possible
@@ -61,7 +33,7 @@ foreach l:libraries
        sources = []
        headers = []
        includes = []
-       cflags = []
+       cflags = [machine_arg]
        objs = [] # other object files to link against, used e.g. for
                  # instruction-set optimized versions of code
 
@@ -85,11 +57,14 @@ foreach l:libraries
 
                if sources.length() == 0
                        # if no C files, just set a dependency on header path
-                       dep = declare_dependency(include_directories: includes)
+                       shared_dep = declare_dependency(include_directories: includes)
+                       static_dep = shared_dep
                else
-                       dep_objs = ext_deps
+                       shared_deps = ext_deps
+                       static_deps = ext_deps
                        foreach d:deps
-                               dep_objs += [get_variable('dep_rte_' + d)]
+                               shared_deps += [get_variable('shared_rte_' + d)]
+                               static_deps += [get_variable('static_rte_' + d)]
                        endforeach
 
                        if allow_experimental_apis
@@ -106,26 +81,42 @@ foreach l:libraries
                                so_version = lib_version
                        endif
 
+                       # first build static lib
+                       static_lib = static_library(libname,
+                                       sources,
+                                       objects: objs,
+                                       c_args: cflags,
+                                       dependencies: static_deps,
+                                       include_directories: includes,
+                                       install: true)
+                       static_dep = declare_dependency(link_with: static_lib,
+                                       include_directories: includes,
+                                       dependencies: static_deps)
+
+                       # then use pre-build objects to build shared lib
+                       sources = []
+                       objs += static_lib.extract_all_objects()
                        version_map = '@0@/@1@/rte_@2@_version.map'.format(
                                        meson.current_source_dir(), dir_name, name)
-                       lib = library(libname,
+                       shared_lib = shared_library(libname,
                                        sources,
                                        objects: objs,
                                        c_args: cflags,
-                                       dependencies: dep_objs,
+                                       dependencies: shared_deps,
                                        include_directories: includes,
                                        link_args: '-Wl,--version-script=' + version_map,
                                        link_depends: version_map,
                                        version: lib_version,
                                        soversion: so_version,
                                        install: true)
-                       dep = declare_dependency(link_with: lib,
+                       shared_dep = declare_dependency(link_with: shared_lib,
                                        include_directories: includes,
-                                       dependencies: dep_objs)
+                                       dependencies: shared_deps)
 
-                       dpdk_libraries = [lib] + dpdk_libraries
+                       dpdk_libraries = [shared_lib] + dpdk_libraries
                endif # sources.length() > 0
 
-               set_variable('dep_' + libname, dep)
+               set_variable('shared_' + libname, shared_dep)
+               set_variable('static_' + libname, static_dep)
        endif # if build
 endforeach