mk: build with _GNU_SOURCE defined by default
[dpdk.git] / test / test / meson.build
index 0ff568f..7c6e3b0 100644 (file)
@@ -7,6 +7,8 @@ test_sources = files('commands.c',
        'test_acl.c',
        'test_alarm.c',
        'test_atomic.c',
+       'test_barrier.c',
+       'test_bpf.c',
        'test_byteorder.c',
        'test_cmdline.c',
        'test_cmdline_cirbuf.c',
@@ -19,9 +21,11 @@ test_sources = files('commands.c',
        'test_common.c',
        'test_cpuflags.c',
        'test_crc.c',
+       'test_cryptodev.c',
+       'test_cryptodev_asym.c',
+       'test_cryptodev_blockcipher.c',
        'test_cycles.c',
        'test_debug.c',
-       'test_devargs.c',
        'test_distributor.c',
        'test_distributor_perf.c',
        'test_eal_flags.c',
@@ -29,9 +33,14 @@ test_sources = files('commands.c',
        'test_efd.c',
        'test_efd_perf.c',
        'test_errno.c',
+       'test_event_crypto_adapter.c',
+       'test_event_eth_rx_adapter.c',
        'test_event_ring.c',
+       'test_event_eth_tx_adapter.c',
+       'test_event_timer_adapter.c',
        'test_eventdev.c',
        'test_func_reentrancy.c',
+       'test_flow_classify.c',
        'test_hash.c',
        'test_hash_functions.c',
        'test_hash_multiwriter.c',
@@ -40,6 +49,8 @@ test_sources = files('commands.c',
        'test_interrupts.c',
        'test_kni.c',
        'test_kvargs.c',
+       'test_link_bonding.c',
+       'test_link_bonding_mode4.c',
        'test_logs.c',
        'test_lpm.c',
        'test_lpm6.c',
@@ -47,6 +58,8 @@ test_sources = files('commands.c',
        'test_lpm_perf.c',
        'test_malloc.c',
        'test_mbuf.c',
+       'test_member.c',
+       'test_member_perf.c',
        'test_memcpy.c',
        'test_memcpy_perf.c',
        'test_memory.c',
@@ -57,10 +70,14 @@ test_sources = files('commands.c',
        'test_mp_secondary.c',
        'test_per_lcore.c',
        'test_pmd_perf.c',
+       'test_pmd_ring.c',
+       'test_pmd_ring_perf.c',
        'test_power.c',
        'test_power_acpi_cpufreq.c',
        'test_power_kvm_vm.c',
        'test_prefetch.c',
+       'test_reciprocal_division.c',
+       'test_reciprocal_division_perf.c',
        'test_red.c',
        'test_reorder.c',
        'test_ring.c',
@@ -86,6 +103,7 @@ test_sources = files('commands.c',
 )
 
 test_deps = ['acl',
+       'bpf',
        'cfgfile',
        'cmdline',
        'cryptodev',
@@ -93,11 +111,12 @@ test_deps = ['acl',
        'efd',
        'ethdev',
        'eventdev',
+       'flow_classify',
        'hash',
        'lpm',
+       'member',
        'pipeline',
        'port',
-       'power',
        'reorder',
        'ring',
        'timer'
@@ -107,11 +126,26 @@ test_names = [
        'acl_autotest',
        'alarm_autotest',
        'atomic_autotest',
+       'barrier_autotest',
        'byteorder_autotest',
        'cmdline_autotest',
        'common_autotest',
        'cpuflags_autotest',
        'crc_autotest',
+       'cryptodev_qat_autotest',
+       'cryptodev_aesni_mb_autotest',
+       'cryptodev_openssl_autotest',
+       'cryptodev_openssl_asym_autotest',
+       'cryptodev_aesni_gcm_autotest',
+       'cryptodev_null_autotest',
+       'cryptodev_sw_snow3g_autotest',
+       'cryptodev_sw_kasumi_autotest',
+       'cryptodev_sw_zuc_autotest',
+       'cryptodev_sw_armv8_autotest',
+       'cryptodev_sw_mvsam_autotest',
+       'cryptodev_dpaa2_sec_autotest',
+       'cryptodev_dpaa_sec_autotest',
+       'cryptodev_octeontx_autotest',
        'cycles_autotest',
        'debug_autotest',
        'devargs_autotest',
@@ -122,11 +156,18 @@ test_names = [
        'efd_autotest',
        'efd_perf_autotest',
        'errno_autotest',
+       'event_crypto_adapter_autotest',
+       'event_eth_rx_adapter_autotest',
+       'event_eth_rx_intr_adapter_autotest',
        'event_ring_autotest',
+       'event_eth_tx_adapter_autotest',
+       'event_timer_adapter_autotest',
        'eventdev_common_autotest',
        'eventdev_octeontx_autotest',
        'eventdev_sw_autotest',
+       'external_mem_autotest',
        'func_reentrancy_autotest',
+       'flow_classify_autotest',
        'hash_scaling_autotest',
        'hash_autotest',
        'hash_functions_autotest',
@@ -135,6 +176,8 @@ test_names = [
        'interrupt_autotest',
        'kni_autotest',
        'kvargs_autotest',
+       'link_bonding_autotest',
+       'link_bonding_mode4_autotest',
        'logs_autotest',
        'lpm6_autotest',
        'lpm6_perf_autotest',
@@ -142,6 +185,8 @@ test_names = [
        'lpm_perf_autotest',
        'malloc_autotest',
        'mbuf_autotest',
+       'member_autotest',
+       'member_perf_autotest',
        'memcpy_autotest',
        'memcpy_perf_autotest',
        'memory_autotest',
@@ -156,16 +201,21 @@ test_names = [
        'power_autotest',
        'power_kvm_vm_autotest',
        'prefetch_autotest',
+       'reciprocal_division',
+       'reciprocal_division_perf',
        'red_all',
        'red_autotest',
        'red_perf',
        'reorder_autotest',
        'ring_autotest',
        'ring_perf_autotest',
+       'ring_pmd_autotest',
+       'ring_pmd_perf_autotest',
        'rwlock_autotest',
        'sched_autotest',
        'service_autotest',
        'spinlock_autotest',
+       'string_autotest',
        'table_autotest',
        'tailq_autotest',
        'thash_autotest',
@@ -185,12 +235,41 @@ endif
 if dpdk_conf.has('RTE_LIBRTE_IXGBE_PMD')
        test_deps += 'pmd_ixgbe'
 endif
+if dpdk_conf.has('RTE_LIBRTE_BOND_PMD')
+       test_deps += 'pmd_bond'
+endif
+if dpdk_conf.has('RTE_LIBRTE_RING_PMD')
+       test_deps += 'pmd_ring'
+endif
+if dpdk_conf.has('RTE_LIBRTE_POWER')
+       test_deps += 'power'
+endif
+if dpdk_conf.has('RTE_LIBRTE_KNI')
+       test_deps += 'kni'
+endif
+
+cflags = machine_args
+if cc.has_argument('-Wno-format-truncation')
+    cflags += '-Wno-format-truncation'
+endif
+
+# specify -D_GNU_SOURCE unconditionally
+default_cflags += '-D_GNU_SOURCE'
 
 test_dep_objs = []
+compress_test_dep = dependency('zlib', required: false)
+if compress_test_dep.found()
+       test_dep_objs += compress_test_dep
+       test_sources += 'test_compressdev.c'
+       test_deps += 'compressdev'
+       test_names += 'compressdev_autotest'
+endif
+
 foreach d:test_deps
        def_lib = get_option('default_library')
        test_dep_objs += get_variable(def_lib + '_rte_' + d)
 endforeach
+test_dep_objs += cc.find_library('execinfo', required: false)
 
 link_libs = []
 if get_option('default_library') == 'static'
@@ -202,7 +281,7 @@ if get_option('tests')
                test_sources,
                link_whole: link_libs,
                dependencies: test_dep_objs,
-               c_args: [machine_arg, '-DALLOW_EXPERIMENTAL_API'],
+               c_args: [cflags, '-DALLOW_EXPERIMENTAL_API'],
                install_rpath: driver_install_path,
                install: false)