mk: build with _GNU_SOURCE defined by default
[dpdk.git] / test / test / meson.build
index 3c8edf5..7c6e3b0 100644 (file)
@@ -8,6 +8,7 @@ test_sources = files('commands.c',
        'test_alarm.c',
        'test_atomic.c',
        'test_barrier.c',
+       'test_bpf.c',
        'test_byteorder.c',
        'test_cmdline.c',
        'test_cmdline_cirbuf.c',
@@ -21,6 +22,7 @@ test_sources = files('commands.c',
        'test_cpuflags.c',
        'test_crc.c',
        'test_cryptodev.c',
+       'test_cryptodev_asym.c',
        'test_cryptodev_blockcipher.c',
        'test_cycles.c',
        'test_debug.c',
@@ -31,7 +33,11 @@ test_sources = files('commands.c',
        'test_efd.c',
        'test_efd_perf.c',
        'test_errno.c',
+       'test_event_crypto_adapter.c',
+       'test_event_eth_rx_adapter.c',
        'test_event_ring.c',
+       'test_event_eth_tx_adapter.c',
+       'test_event_timer_adapter.c',
        'test_eventdev.c',
        'test_func_reentrancy.c',
        'test_flow_classify.c',
@@ -97,6 +103,7 @@ test_sources = files('commands.c',
 )
 
 test_deps = ['acl',
+       'bpf',
        'cfgfile',
        'cmdline',
        'cryptodev',
@@ -128,6 +135,7 @@ test_names = [
        'cryptodev_qat_autotest',
        'cryptodev_aesni_mb_autotest',
        'cryptodev_openssl_autotest',
+       'cryptodev_openssl_asym_autotest',
        'cryptodev_aesni_gcm_autotest',
        'cryptodev_null_autotest',
        'cryptodev_sw_snow3g_autotest',
@@ -137,6 +145,7 @@ test_names = [
        'cryptodev_sw_mvsam_autotest',
        'cryptodev_dpaa2_sec_autotest',
        'cryptodev_dpaa_sec_autotest',
+       'cryptodev_octeontx_autotest',
        'cycles_autotest',
        'debug_autotest',
        'devargs_autotest',
@@ -147,10 +156,16 @@ test_names = [
        'efd_autotest',
        'efd_perf_autotest',
        'errno_autotest',
+       'event_crypto_adapter_autotest',
+       'event_eth_rx_adapter_autotest',
+       'event_eth_rx_intr_adapter_autotest',
        'event_ring_autotest',
+       'event_eth_tx_adapter_autotest',
+       'event_timer_adapter_autotest',
        'eventdev_common_autotest',
        'eventdev_octeontx_autotest',
        'eventdev_sw_autotest',
+       'external_mem_autotest',
        'func_reentrancy_autotest',
        'flow_classify_autotest',
        'hash_scaling_autotest',
@@ -233,6 +248,14 @@ if dpdk_conf.has('RTE_LIBRTE_KNI')
        test_deps += 'kni'
 endif
 
+cflags = machine_args
+if cc.has_argument('-Wno-format-truncation')
+    cflags += '-Wno-format-truncation'
+endif
+
+# specify -D_GNU_SOURCE unconditionally
+default_cflags += '-D_GNU_SOURCE'
+
 test_dep_objs = []
 compress_test_dep = dependency('zlib', required: false)
 if compress_test_dep.found()
@@ -258,7 +281,7 @@ if get_option('tests')
                test_sources,
                link_whole: link_libs,
                dependencies: test_dep_objs,
-               c_args: [machine_args, '-DALLOW_EXPERIMENTAL_API'],
+               c_args: [cflags, '-DALLOW_EXPERIMENTAL_API'],
                install_rpath: driver_install_path,
                install: false)