mk: build with _GNU_SOURCE defined by default
[dpdk.git] / test / test / meson.build
index 6a71ee0..7c6e3b0 100644 (file)
@@ -145,6 +145,7 @@ test_names = [
        'cryptodev_sw_mvsam_autotest',
        'cryptodev_dpaa2_sec_autotest',
        'cryptodev_dpaa_sec_autotest',
+       'cryptodev_octeontx_autotest',
        'cycles_autotest',
        'debug_autotest',
        'devargs_autotest',
@@ -252,6 +253,9 @@ if cc.has_argument('-Wno-format-truncation')
     cflags += '-Wno-format-truncation'
 endif
 
+# specify -D_GNU_SOURCE unconditionally
+default_cflags += '-D_GNU_SOURCE'
+
 test_dep_objs = []
 compress_test_dep = dependency('zlib', required: false)
 if compress_test_dep.found()