mk: build with _GNU_SOURCE defined by default
[dpdk.git] / test / test / meson.build
index b8bae5a..7c6e3b0 100644 (file)
@@ -7,6 +7,8 @@ test_sources = files('commands.c',
        'test_acl.c',
        'test_alarm.c',
        'test_atomic.c',
+       'test_barrier.c',
+       'test_bpf.c',
        'test_byteorder.c',
        'test_cmdline.c',
        'test_cmdline_cirbuf.c',
@@ -20,10 +22,10 @@ test_sources = files('commands.c',
        'test_cpuflags.c',
        'test_crc.c',
        'test_cryptodev.c',
+       'test_cryptodev_asym.c',
        'test_cryptodev_blockcipher.c',
        'test_cycles.c',
        'test_debug.c',
-       'test_devargs.c',
        'test_distributor.c',
        'test_distributor_perf.c',
        'test_eal_flags.c',
@@ -31,7 +33,11 @@ test_sources = files('commands.c',
        'test_efd.c',
        'test_efd_perf.c',
        'test_errno.c',
+       'test_event_crypto_adapter.c',
+       'test_event_eth_rx_adapter.c',
        'test_event_ring.c',
+       'test_event_eth_tx_adapter.c',
+       'test_event_timer_adapter.c',
        'test_eventdev.c',
        'test_func_reentrancy.c',
        'test_flow_classify.c',
@@ -70,6 +76,8 @@ test_sources = files('commands.c',
        'test_power_acpi_cpufreq.c',
        'test_power_kvm_vm.c',
        'test_prefetch.c',
+       'test_reciprocal_division.c',
+       'test_reciprocal_division_perf.c',
        'test_red.c',
        'test_reorder.c',
        'test_ring.c',
@@ -95,6 +103,7 @@ test_sources = files('commands.c',
 )
 
 test_deps = ['acl',
+       'bpf',
        'cfgfile',
        'cmdline',
        'cryptodev',
@@ -108,7 +117,6 @@ test_deps = ['acl',
        'member',
        'pipeline',
        'port',
-       'power',
        'reorder',
        'ring',
        'timer'
@@ -118,6 +126,7 @@ test_names = [
        'acl_autotest',
        'alarm_autotest',
        'atomic_autotest',
+       'barrier_autotest',
        'byteorder_autotest',
        'cmdline_autotest',
        'common_autotest',
@@ -126,15 +135,17 @@ test_names = [
        'cryptodev_qat_autotest',
        'cryptodev_aesni_mb_autotest',
        'cryptodev_openssl_autotest',
+       'cryptodev_openssl_asym_autotest',
        'cryptodev_aesni_gcm_autotest',
        'cryptodev_null_autotest',
        'cryptodev_sw_snow3g_autotest',
        'cryptodev_sw_kasumi_autotest',
        'cryptodev_sw_zuc_autotest',
        'cryptodev_sw_armv8_autotest',
-       'cryptodev_sw_mrvl_autotest',
+       'cryptodev_sw_mvsam_autotest',
        'cryptodev_dpaa2_sec_autotest',
        'cryptodev_dpaa_sec_autotest',
+       'cryptodev_octeontx_autotest',
        'cycles_autotest',
        'debug_autotest',
        'devargs_autotest',
@@ -145,10 +156,16 @@ test_names = [
        'efd_autotest',
        'efd_perf_autotest',
        'errno_autotest',
+       'event_crypto_adapter_autotest',
+       'event_eth_rx_adapter_autotest',
+       'event_eth_rx_intr_adapter_autotest',
        'event_ring_autotest',
+       'event_eth_tx_adapter_autotest',
+       'event_timer_adapter_autotest',
        'eventdev_common_autotest',
        'eventdev_octeontx_autotest',
        'eventdev_sw_autotest',
+       'external_mem_autotest',
        'func_reentrancy_autotest',
        'flow_classify_autotest',
        'hash_scaling_autotest',
@@ -184,6 +201,8 @@ test_names = [
        'power_autotest',
        'power_kvm_vm_autotest',
        'prefetch_autotest',
+       'reciprocal_division',
+       'reciprocal_division_perf',
        'red_all',
        'red_autotest',
        'red_perf',
@@ -222,12 +241,35 @@ endif
 if dpdk_conf.has('RTE_LIBRTE_RING_PMD')
        test_deps += 'pmd_ring'
 endif
+if dpdk_conf.has('RTE_LIBRTE_POWER')
+       test_deps += 'power'
+endif
+if dpdk_conf.has('RTE_LIBRTE_KNI')
+       test_deps += 'kni'
+endif
+
+cflags = machine_args
+if cc.has_argument('-Wno-format-truncation')
+    cflags += '-Wno-format-truncation'
+endif
+
+# specify -D_GNU_SOURCE unconditionally
+default_cflags += '-D_GNU_SOURCE'
 
 test_dep_objs = []
+compress_test_dep = dependency('zlib', required: false)
+if compress_test_dep.found()
+       test_dep_objs += compress_test_dep
+       test_sources += 'test_compressdev.c'
+       test_deps += 'compressdev'
+       test_names += 'compressdev_autotest'
+endif
+
 foreach d:test_deps
        def_lib = get_option('default_library')
        test_dep_objs += get_variable(def_lib + '_rte_' + d)
 endforeach
+test_dep_objs += cc.find_library('execinfo', required: false)
 
 link_libs = []
 if get_option('default_library') == 'static'
@@ -239,7 +281,7 @@ if get_option('tests')
                test_sources,
                link_whole: link_libs,
                dependencies: test_dep_objs,
-               c_args: [machine_args, '-DALLOW_EXPERIMENTAL_API'],
+               c_args: [cflags, '-DALLOW_EXPERIMENTAL_API'],
                install_rpath: driver_install_path,
                install: false)