examples/pipeline: add selector example
[dpdk.git] / examples / pipeline / examples / l2fwd.spec
1 ; SPDX-License-Identifier: BSD-3-Clause
2 ; Copyright(c) 2020 Intel Corporation
3
4 //
5 // Meta-data.
6 //
7 struct metadata_t {
8         bit<32> port_in
9         bit<32> port_out
10 }
11
12 metadata instanceof metadata_t
13
14 //
15 // Actions.
16 //
17 action NoAction args none {
18         return
19 }
20
21 //
22 // Tables.
23 //
24 table stub {
25         key {
26         }
27
28         actions {
29                 NoAction
30         }
31
32         default_action NoAction args none const
33 }
34
35 //
36 // Pipeline.
37 //
38 apply {
39         rx m.port_in
40         table stub
41         tx m.port_in
42 }