drivers: move ifc to vDPA directory
[dpdk.git] / drivers / vdpa / ifc / meson.build
diff --git a/drivers/vdpa/ifc/meson.build b/drivers/vdpa/ifc/meson.build
new file mode 100644 (file)
index 0000000..adc9ed9
--- /dev/null
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2018 Intel Corporation
+
+build = dpdk_conf.has('RTE_LIBRTE_VHOST')
+reason = 'missing dependency, DPDK vhost library'
+allow_experimental_apis = true
+sources = files('ifcvf_vdpa.c', 'base/ifcvf.c')
+includes += include_directories('base')
+deps += 'vhost'