scripts: move to buildtools
[dpdk.git] / pkg / dpdk.spec
1 # Copyright 2014 6WIND S.A.
2 #
3 # Redistribution and use in source and binary forms, with or without
4 # modification, are permitted provided that the following conditions
5 # are met:
6 #
7 # - Redistributions of source code must retain the above copyright
8 #   notice, this list of conditions and the following disclaimer.
9 #
10 # - Redistributions in binary form must reproduce the above copyright
11 #   notice, this list of conditions and the following disclaimer in
12 #   the documentation and/or other materials provided with the
13 #   distribution.
14 #
15 # - Neither the name of 6WIND S.A. nor the names of its
16 #   contributors may be used to endorse or promote products derived
17 #   from this software without specific prior written permission.
18 #
19 # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
20 # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
21 # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
22 # FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
23 # COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
24 # INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
25 # (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
26 # SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
27 # HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
28 # STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
29 # ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
30 # OF THE POSSIBILITY OF SUCH DAMAGE.
31
32 Name: dpdk
33 Version: 16.11
34 Release: 1
35 Packager: packaging@6wind.com
36 URL: http://dpdk.org
37 Source: http://dpdk.org/browse/dpdk/snapshot/dpdk-%{version}.tar.gz
38
39 Summary: Data Plane Development Kit core
40 Group: System Environment/Libraries
41 License: BSD and LGPLv2 and GPLv2
42
43 ExclusiveArch: i686, x86_64
44 %global machine default
45 %global target %{_arch}-%{machine}-linuxapp-gcc
46 %global config %{_arch}-native-linuxapp-gcc
47
48 BuildRequires: kernel-devel, kernel-headers, libpcap-devel, xen-devel
49 BuildRequires: doxygen, python-sphinx, inkscape
50 BuildRequires: texlive-collection-latexextra
51
52 %description
53 DPDK core includes kernel modules, core libraries and tools.
54 testpmd application allows to test fast packet processing environments
55 on x86 platforms. For instance, it can be used to check that environment
56 can support fast path applications such as 6WINDGate, pktgen, rumptcpip, etc.
57 More libraries are available as extensions in other packages.
58
59 %package devel
60 Summary: Data Plane Development Kit for development
61 Requires: %{name}%{?_isa} = %{version}-%{release}
62 %description devel
63 DPDK devel is a set of makefiles, headers and examples
64 for fast packet processing on x86 platforms.
65
66 %package doc
67 Summary: Data Plane Development Kit API documentation
68 BuildArch: noarch
69 %description doc
70 DPDK doc is divided in two parts: API details in doxygen HTML format
71 and guides in sphinx HTML/PDF formats.
72
73 %prep
74 %setup -q
75
76 %build
77 make O=%{target} T=%{config} config
78 sed -ri 's,(RTE_MACHINE=).*,\1%{machine},' %{target}/.config
79 sed -ri 's,(RTE_APP_TEST=).*,\1n,'         %{target}/.config
80 sed -ri 's,(RTE_BUILD_SHARED_LIB=).*,\1y,' %{target}/.config
81 sed -ri 's,(RTE_NEXT_ABI=).*,\1n,'         %{target}/.config
82 sed -ri 's,(LIBRTE_VHOST=).*,\1y,'         %{target}/.config
83 sed -ri 's,(LIBRTE_PMD_PCAP=).*,\1y,'      %{target}/.config
84 sed -ri 's,(LIBRTE_PMD_XENVIRT=).*,\1y,'   %{target}/.config
85 make O=%{target} %{?_smp_mflags}
86 make O=%{target} doc
87
88 %install
89 rm -rf %{buildroot}
90 make install O=%{target} DESTDIR=%{buildroot} \
91         prefix=%{_prefix} bindir=%{_bindir} sbindir=%{_sbindir} \
92         includedir=%{_includedir}/dpdk libdir=%{_libdir} \
93         datadir=%{_datadir}/dpdk docdir=%{_docdir}/dpdk
94
95 %files
96 %dir %{_datadir}/dpdk
97 %{_datadir}/dpdk/tools
98 /lib/modules/%(uname -r)/extra/*
99 %{_sbindir}/*
100 %{_bindir}/*
101 %{_libdir}/*
102
103 %files devel
104 %{_includedir}/dpdk
105 %{_datadir}/dpdk/mk
106 %{_datadir}/dpdk/buildtools
107 %{_datadir}/dpdk/%{target}
108 %{_datadir}/dpdk/examples
109
110 %files doc
111 %doc %{_docdir}/dpdk
112
113 %post
114 /sbin/ldconfig
115 /sbin/depmod
116
117 %postun
118 /sbin/ldconfig
119 /sbin/depmod