pkg: remove -core file suffix
[dpdk.git] / pkg / dpdk.spec
1 # Copyright 2014 6WIND S.A.
2 #
3 # Redistribution and use in source and binary forms, with or without
4 # modification, are permitted provided that the following conditions
5 # are met:
6 #
7 # - Redistributions of source code must retain the above copyright
8 #   notice, this list of conditions and the following disclaimer.
9 #
10 # - Redistributions in binary form must reproduce the above copyright
11 #   notice, this list of conditions and the following disclaimer in
12 #   the documentation and/or other materials provided with the
13 #   distribution.
14 #
15 # - Neither the name of 6WIND S.A. nor the names of its
16 #   contributors may be used to endorse or promote products derived
17 #   from this software without specific prior written permission.
18 #
19 # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
20 # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
21 # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
22 # FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
23 # COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
24 # INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
25 # (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
26 # SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
27 # HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
28 # STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
29 # ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
30 # OF THE POSSIBILITY OF SUCH DAMAGE.
31
32 Name: dpdk
33 Version: 1.8.0
34 Release: 1
35 Packager: packaging@6wind.com
36 URL: http://dpdk.org
37 Source: http://dpdk.org/browse/dpdk/snapshot/dpdk-%{version}.tar.gz
38
39 Summary: Data Plane Development Kit core
40 Group: System Environment/Libraries
41 License: BSD and LGPLv2 and GPLv2
42
43 ExclusiveArch: i686, x86_64
44 %global target %{_arch}-native-linuxapp-gcc
45 %global machine default
46
47 BuildRequires: kernel-devel, kernel-headers, libpcap-devel, xen-devel, doxygen, python-sphinx
48
49 %description
50 DPDK core includes kernel modules, core libraries and tools.
51 testpmd application allows to test fast packet processing environments
52 on x86 platforms. For instance, it can be used to check that environment
53 can support fast path applications such as 6WINDGate, pktgen, rumptcpip, etc.
54 More libraries are available as extensions in other packages.
55
56 %package devel
57 Summary: Data Plane Development Kit for development
58 Requires: %{name}%{?_isa} = %{version}-%{release}
59 %description devel
60 DPDK devel is a set of makefiles, headers and examples
61 for fast packet processing on x86 platforms.
62
63 %package doc
64 Summary: Data Plane Development Kit API documentation
65 BuildArch: noarch
66 %description doc
67 DPDK doc is divided in two parts: API details in doxygen HTML format
68 and guides in sphinx HTML format.
69
70 %global destdir %{buildroot}%{_prefix}
71 %global moddir  /lib/modules/%(uname -r)/extra
72 %global datadir %{_datadir}/dpdk
73 %global docdir  %{_docdir}/dpdk
74
75 %prep
76 %setup -q
77
78 %build
79 make O=%{target} T=%{target} config
80 sed -ri 's,(RTE_MACHINE=).*,\1%{machine},' %{target}/.config
81 sed -ri 's,(RTE_APP_TEST=).*,\1n,'         %{target}/.config
82 sed -ri 's,(RTE_BUILD_SHARED_LIB=).*,\1y,' %{target}/.config
83 sed -ri 's,(LIBRTE_PMD_PCAP=).*,\1y,'      %{target}/.config
84 sed -ri 's,(LIBRTE_PMD_XENVIRT=).*,\1y,'   %{target}/.config
85 sed -ri 's,(LIBRTE_XEN_DOM0=).*,\1y,'      %{target}/.config
86 make O=%{target} %{?_smp_mflags}
87 make O=%{target} doc
88
89 %install
90 rm -rf %{buildroot}
91 make            O=%{target}      DESTDIR=%{destdir}
92 mkdir -p                                 %{buildroot}%{moddir}
93 mv     %{destdir}/%{target}/kmod/*.ko    %{buildroot}%{moddir}
94 rmdir  %{destdir}/%{target}/kmod
95 mkdir -p                                 %{buildroot}%{_sbindir}
96 ln -s  %{datadir}/tools/*nic_bind.py     %{buildroot}%{_sbindir}/dpdk_nic_bind
97 mkdir -p                                 %{buildroot}%{_bindir}
98 mv     %{destdir}/%{target}/app/testpmd  %{buildroot}%{_bindir}
99 rmdir  %{destdir}/%{target}/app
100 mv     %{destdir}/%{target}/include      %{buildroot}%{_includedir}
101 mv     %{destdir}/%{target}/lib          %{buildroot}%{_libdir}
102 mkdir -p                                 %{buildroot}%{docdir}
103 mv     %{destdir}/%{target}/doc/*        %{buildroot}%{docdir}
104 rmdir  %{destdir}/%{target}/doc
105 mkdir -p                                 %{buildroot}%{datadir}
106 mv     %{destdir}/%{target}/.config      %{buildroot}%{datadir}/config
107 mv     %{destdir}/%{target}              %{buildroot}%{datadir}
108 mv     %{destdir}/scripts                %{buildroot}%{datadir}
109 mv     %{destdir}/mk                     %{buildroot}%{datadir}
110 cp -a             examples               %{buildroot}%{datadir}
111 cp -a             tools                  %{buildroot}%{datadir}
112 ln -s             %{datadir}/config      %{buildroot}%{datadir}/%{target}/.config
113 ln -s             %{_includedir}         %{buildroot}%{datadir}/%{target}/include
114 ln -s             %{_libdir}             %{buildroot}%{datadir}/%{target}/lib
115
116 %files
117 %dir %{datadir}
118 %{datadir}/config
119 %{datadir}/tools
120 %{moddir}/*
121 %{_sbindir}/*
122 %{_bindir}/*
123 %{_libdir}/*
124
125 %files devel
126 %{_includedir}/*
127 %{datadir}/mk
128 %{datadir}/scripts
129 %{datadir}/%{target}
130 %{datadir}/examples
131
132 %files doc
133 %doc %{docdir}
134
135 %post
136 /sbin/ldconfig
137 /sbin/depmod
138
139 %postun
140 /sbin/ldconfig
141 /sbin/depmod