build: add workarounds for Windows helloworld
[dpdk.git] / app / meson.build
index 2360a3d..e949624 100644 (file)
@@ -1,5 +1,9 @@
 # SPDX-License-Identifier: BSD-3-Clause
-# Copyright(c) 2017 Intel Corporation
+# Copyright(c) 2017-2019 Intel Corporation
+
+if host_machine.system() == 'windows'
+       subdir_done()
+endif
 
 apps = [
        'pdump',
@@ -65,3 +69,6 @@ foreach app:apps
                                install: true)
        endif
 endforeach
+
+# special case the autotests
+subdir('test')