build: add workarounds for Windows helloworld
[dpdk.git] / app / meson.build
index 47a2a86..e949624 100644 (file)
@@ -1,12 +1,20 @@
 # SPDX-License-Identifier: BSD-3-Clause
-# Copyright(c) 2017 Intel Corporation
+# Copyright(c) 2017-2019 Intel Corporation
 
-apps = ['pdump',
+if host_machine.system() == 'windows'
+       subdir_done()
+endif
+
+apps = [
+       'pdump',
        'proc-info',
+       'test-acl',
        'test-bbdev',
+       'test-cmdline',
        'test-compress-perf',
        'test-crypto-perf',
        'test-eventdev',
+       'test-pipeline',
        'test-pmd']
 
 # for BSD only
@@ -61,3 +69,6 @@ foreach app:apps
                                install: true)
        endif
 endforeach
+
+# special case the autotests
+subdir('test')