build: add workarounds for Windows helloworld
[dpdk.git] / app / meson.build
index e68d949..e949624 100644 (file)
@@ -1,11 +1,20 @@
 # SPDX-License-Identifier: BSD-3-Clause
-# Copyright(c) 2017 Intel Corporation
+# Copyright(c) 2017-2019 Intel Corporation
 
-apps = ['pdump',
+if host_machine.system() == 'windows'
+       subdir_done()
+endif
+
+apps = [
+       'pdump',
        'proc-info',
+       'test-acl',
        'test-bbdev',
+       'test-cmdline',
+       'test-compress-perf',
        'test-crypto-perf',
        'test-eventdev',
+       'test-pipeline',
        'test-pmd']
 
 # for BSD only
@@ -29,7 +38,7 @@ foreach app:apps
        # use "deps" for internal DPDK dependencies, and "ext_deps" for
        # external package/library requirements
        ext_deps = []
-       deps = []
+       deps = dpdk_app_link_libraries
 
        subdir(name)
 
@@ -43,7 +52,7 @@ foreach app:apps
 
                link_libs = []
                if get_option('default_library') == 'static'
-                       link_libs = dpdk_drivers
+                       link_libs = dpdk_static_libraries + dpdk_drivers
                endif
 
                if allow_experimental_apis
@@ -60,3 +69,6 @@ foreach app:apps
                                install: true)
        endif
 endforeach
+
+# special case the autotests
+subdir('test')