build: add workarounds for Windows helloworld
[dpdk.git] / examples / meson.build
index 3d15684..d72382f 100644 (file)
@@ -1,5 +1,5 @@
 # SPDX-License-Identifier: BSD-3-Clause
-# Copyright(c) 2017 Intel Corporation
+# Copyright(c) 2017-2019 Intel Corporation
 
 driver_libs = []
 if get_option('default_library') == 'static'
@@ -18,15 +18,27 @@ else
        examples = get_option('examples').split(',')
        allow_skips = false # error out if we can't build a requested app
 endif
+default_cflags = machine_args
+if cc.has_argument('-Wno-format-truncation')
+       default_cflags += '-Wno-format-truncation'
+endif
+
+# specify -D_GNU_SOURCE unconditionally
+default_cflags += '-D_GNU_SOURCE'
+
 foreach example: examples
        name = example
        build = true
        sources = []
        allow_experimental_apis = false
-       cflags = machine_args
+       cflags = default_cflags
+
        ext_deps = [execinfo]
        includes = [include_directories(example)]
        deps = ['eal', 'mempool', 'net', 'mbuf', 'ethdev', 'cmdline']
+       if host_machine.system() == 'windows'
+               deps = ['eal'] # only supported lib on Windows currently
+       endif
        subdir(example)
 
        if build